سیسکو

پیکربندی DR/BDR در پروتکل OSPF

پیکربندی DR/BDR در پروتکل OSPF روتر سیسکو

پیکربندی DR/BDR در پروتکل OSPF روتر سیسکو

در این مبحث قصد داریم در رابطه با پیکربندی DR/BDR در پروتکل OSPF در روتر سیسکو صحبت کنیم. پروتکل مسیریابی پویا (Open Short Path First) احتمالا محبوب‌ترین و پرکاربردترین پروتکل مسیر یابی IGP در شبکه‌های TCP/IP است. از آنجا که OSPF توسط همه فروشندگان شبکه پشتیبانی می‌شود، محدودیت‌های پروتکل‌های اختصاصی مانند Cisco EIGRP را ندارد (از لحاظ محیط‌های چند فروشنده و غیره).

امتحان جدید سیسکو (200-301) CCNA به دانش OSFP نیاز دارد، که این موضوع نشان دهنده اهمیتی است که سیسکو در این پروتکل مسیریابی پویا قائل است.

اهمیت DR/BDR

یکی از مفاهیمی که باید در مورد OSPF بیاموزید انتخاب DR/BDR در انواع شبکه‌های پخش (شبکه دسترسی چندگانه مانند اترنت LAN است. بنابراین اگر دو یا چند روتر در یک شبکه پخش وصل شده باشند و برای OSPF پیکربندی شده باشند، باید یک DR (مسیریاب تعیین شده) و یک BDR (روتر تعیین شده پشتیبان) را انتخاب کنند. توجه داشته باشید که DR/BDR بر اساس هر بخش و نه بر اساس هر منطقه انجام می‌شود.

همه روترها در شبکه پخش باید یک OSPF همسایه با همه روترهای دیگر تشکیل دهند. هدف DR و BDR کاهش پیچیدگی شبکه چند دسترسی از نقطه نظر پایگاه داده وضعیت Link است.

DR/BDR به عنوان نقاط مرکزی تبادل اطلاعات وضعیت Link عمل می‌کند، به جای اینکه مجبور به تبادل اطلاعات با همه روترهای دیگر در شبکه پخش مش باشد. این امر پایگاه داده وضعیت Link روترها را تا حد زیادی کاهش می‌دهد.

توجه داشته باشید که هیچ DR/BDR در شبکه های نقطه به نقطه (مثلا در لینک های سریال) انتخاب نشده است.

عوامل موثر بر انتخاب DR/BDR

دو عامل وجود دارد که بر انتخاب DR/BDR تاثیر می‌گذارد که در زیر برایتان شرح دادیم:

شناسه روتر : شناسه روتر بالاترین آدرس IP دستگاه یا بالاترین آدرس IP در بین آدرس های Loopback (در صورت کانفیگ بودن) روی روتر سیسکو است یا می‌تواند به صورت دستی با دستور router-id a.b.c.d تحت فرایند OSPF پیکربندی شود.

اولویت OSPF : این به طور پیش فرض اول برای همه روترها است. اولویت OSPF در هر رابط پیکربندی می‌شود.

قوانین انتخاب DR/BDR

روتر با بالاترین اولویت OSPF در یک بخش خاص (رابط روتر) به DR تبدیل می‌شود. در صورت تساوی (یعنی همان اولویت OSPF) روتر با بالاترین شناسه روتر تبدیل به DR می‌شود. بزرگترین شناسه روتر بعدی BDR خواهد بود. از آنجایی که به طور پیش فرض همه روترها دارای اولویت OSPF 1 هستند، به این معنی است که روتری که بالاترین آدرس IP را دارد (یعنی بالاترین شناسه روتر) به DR تبدیل می‌شود. ما می توانیم با پیکربندی صریح Router ID یا اولویت OSPF روی روترها بر انتخاب DR و BDR تاثیر بگذاریم.

مثال سناریوی پیکربندی

بیایید نمونه توپولوژی زیر را با 4 روتر ببینیم (R1 از طریق پیوند نقطه به نقطه به R2 و R2، R3، R4 به یک شبکه پخش چند دسترسی متصل است).[

مرحله 1 : آدرس های IP را در روتر ها پیکربندی کنید

R1#conf t
R1(config)#interface serial 0/0/0
R1(config-if)#ip address 192.168.12.1 255.255.255.252
R1(config-if)#clock rate 2000000
R1(config-if)#no shut
R1(config-if)#exit

R1(config)#interface GigabitEthernet0/0
R1(config-if)#ip address 192.168.4.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#

R2#conf t
R2(config)#interface serial 0/0/0
R2(config-if)#ip address 192.168.12.2 255.255.255.252
R2(config-if)#no shut
R2(config-if)#exit

R2(config)#interface GigabitEthernet0/0
R2(config-if)#ip address 192.168.1.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#

R3#conf t
R3(config)#interface GigabitEthernet0/0
R3(config-if)#ip address 192.168.1.2 255.255.255.0
R3(config-if)#no shut
R3(config-if)#exit

R3(config)#interface GigabitEthernet0/1
R3(config-if)#ip address 192.168.2.1 255.255.255.0
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#
R4#conf t
R4(config)#interface GigabitEthernet0/0
R4(config-if)#ip address 192.168.1.3 255.255.255.0
R4(config-if)#no shut
R4(config-if)#exit

R4(config)#interface GigabitEthernet0/1
R4(config-if)#ip address 192.168.3.1 255.255.255.0
R4(config-if)#no shut
R4(config-if)#exit
R4(config)#

مرحله 2: پیکربندی همه روترها در OSPF Area 0

R1(config)#router ospf 1
R1(config-router)#network 192.168.12.0 0.0.0.3 area 0
R1(config-router)#network 192.168.4.0 0.0.0.255 area 0
R1(config-router)#end
R1#wr

R2(config)#router ospf 1
R2(config-router)#network 192.168.12.0 0.0.0.3 area 0
R2(config-router)#network 192.168.1.0 0.0.0.255 area 0
R2(config-router)#end
R2#wr
R3(config)#router ospf 1
R3(config-router)#network 192.168.1.0 0.0.0.255 area 0
R3(config-router)#network 192.168.2.0 0.0.0.255 area 0
R3(config-router)#end
R3#wr

R4(config)#router ospf 1
R4(config-router)#network 192.168.1.0 0.0.0.255 area 0
R4(config-router)#network 192.168.3.0 0.0.0.255 area 0
R4(config-router)#end
R4#wr

مرحله 3: تأیید – DR/BDR – مجاورت‌های همسایه

R1#show ip ospf neighbor

2.168.12.2 0 FULL/ – 00:00:35 192.168.12.2 Serial0/0/0

تصویر بالا همسایه OSPF R1 را نشان می‌دهد که روتر R2 با شناسه Neighbor ID “192.168.12.2 است.

در واقع شناسه Neighbor روتر همان روتر همسایه است. Router ID بالاترین آدرس IP دستگاه یا بالاترین آدرس IP در بین آدرس های Loopback در صورت پیکربندی روی روتر Cissco است یا می‌تواند به صورت دستی با دستور “router-id a.b.c.d” تحت فرایند OSPF پیکربندی شود.

“State” نشان می‌دهد که این روتر یک رابطه OSPF “FULL” با روتر همسایه برقرار کرده است. این حالت عادی برای روتر OSPF است.

R1#show ip ospf interface serial 0/0/0
Serial0/0/0 is up, line protocol is up
Internet address is 192.168.12.1/30, Area 0
Process ID 1, Router ID 192.168.12.1, Network Type POINT-TO-POINT, Cost:64
Transmit Delay is 1 sec, State POINT-TO-POINT,
[output omitted]

موارد فوق نشان می‌دهد که نوع شبکه OSPF در حال اجرا بر روی رابط سریال Point-to-point است. علاوه بر این، شناسه روتر R1 این “192.168.12.1” است.

R2#show ip ospf neighbor

Neighbor ID    Pri       State                Dead Time      Address             Interface

192.168.3.1       1          FULL/BDR      00:00:38           192.168.1.3 GigabitEthernet0/0
192.168.2.1       1          FULL/DROTHER 00:00:38    192.168.1.2 GigabitEthernet0/0
192.168.12.1     0          FULL/ –           00:00:38           192.168.12.1 Serial0/0/0

روتر R2 از طریق رابط Gi0/0 به یک لینک اتصال نقطه به نقطه (رابط سریال به R1) و همچنین به یک شبکه Multi-Access (دامنه پخش) متصل می شود که از طریق یک سوئیچ اترنت (شبکه پخش) به روترهای دیگر متصل می شود R3 و R4.

همانطور که در بالا توضیح داده شد، روترهای متصل به یک شبکه چند دسترسی (مانند اترنت)، یک DR (مسیریاب تعیین شده) و یک BDR (مسیریاب تعیین شده پشتیبان) را انتخاب می کنند. روتری که به عنوان DR یا BDR انتخاب نشده باشد، DROTHER نامیده می‌شود. روتر با بالاترین مقدار اولویت OSPF به DR تبدیل می‌شود. در صورتی که اولویت‌ها یکسان باشد(اولویت پیش فرض برای همه روتر ها 1 است)، شناسه روتر تبدیل به Tie breaker می‌شود. روتر با بزرگترین IP بعدی (Neighbor ID-192.168.3.1) به BDR تبدیل می‌شود.

در توپولوژی بالا، روتر R2 به عنوان DR انتخاب می شود زیرا دارای بالاترین شناسه روتر 192.168.12.2 است. علاوه بر این، روتر R3 BDR خواهد بود زیرا دارای بالاترین شناسه روتر بعدی 192.168.3.1 است.

R2#show ip protocols

Routing Protocol is “ospf 1”
[output omitted]
Router ID 192.168.12.2

R2#show ip ospf interface gigabitEthernet 0/0

GigabitEthernet0/0 is up, line protocol is up
Internet address is 192.168.1.1/24, Area 0
Process ID 1, Router ID 192.168.12.2, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.12.2, Interface address 192.168.1.1
Backup Designated Router (ID) 192.168.3.1, Interface address 192.168.1.3
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:00
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 192.168.3.1 (Backup Designated Router)
Adjacent with neighbor 192.168.2.1
Suppress hello for 0 neighbor(s)

در مثال بالا، روتر R2 دارای شناسه روتر 192.168.12.2 است که بالاترین شناسه روتر در شبکه Multi-Access است، بنابراین R2 به عنوان DR در OSPF انتخاب می‌شود. علاوه بر این، BDR دارای شناسه روتر 192.168.3.1 می‌باشد.

R3#show ip ospf neighbor

Neighbor ID    Pri       State                Dead Time     Address             Interface

192.168.3.1       1          FULL/BDR      00:00:36           192.168.1.3 GigabitEthernet0/0
192.168.12.2     1          FULL/DR        00:00:36           192.168.1.1 GigabitEthernet0/0

در بالا همسایگان OSPF R3 را نشان می‌دهد. این روتر روابط FULL OSPF را با روتر BDR با شناسه (192.168.3.1) و با روتر DR با شناسه (192.168.12.2) برقرار کرده است.

R4#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface

192.168.2.1 1 FULL/DROTHER 00:00:36 192.168.1.2 GigabitEthernet0/0
192.168.12.2 1 FULL/DR 00:00:36 192.168.1.1 GigabitEthernet0/0

اولویت OSPF و شناسه روتر را برای DR Election پیکربندی کنید. اکنون بیایید ببینیم که چگونه با تغییر اولویت OSPF یا شناسه روتر بر انتخابات DR تاثیر بگذاریم:

همان طور که در بخش قبل مشاهده شد، روتر R2 به عنوان DR انتخاب می شود زیرا دارای بالاترین Router-ID (192.168.12.2) است و از آنجایی که اولویت OSPF به طور پیش فرض در همه روترها 1 است، به این معنی است که R2 DR خواهد بود. ما می‌توانیم با استفاده از دو روش بر انتخابات DR تاثیر بگذاریم درست همان طور که در بالا توضیح داده شد.

1) یک Router-ID بالاتر از هر روتر دیگری در شبکه پیکربندی کنید.

2) اولویت OSPF را بزرگتر از 1 (پیش فرض) پیکربندی کنید.

ما R3 را برای تبدیل شدن به روتر جدید انتخاب شده DR با تغییر پارامترهای بالا انتخاب می‌کنیم.

DR Election را با Router-ID تغییر دهید

بیایید Router-ID را در R3 تغییر دهیم تا بزرگتر شود:

R3#conf t
R3(config)#router ospf 1
R3(config-router)#router-id 192.168.255.1

Reload or use “clear ip ospf process” command, for this to take effect
R3(config-router)#end

R3#clear ip ospf process

Reset ALL OSPF processes? [no]: yes

پس از تنظیم Router-ID R3 (به عنوان 192.168.255.1)، پیامی دریافت خواهید کرد که باید همه روترها را مجدداً بارگیری کنید یا دستور “clear ip ospf process” را برای اعمال این کار اجرا کنید. این Router-ID جدید بالاترین شماره IP در کل شبکه است، بنابراین R3 به DR جدید تبدیل خواهد شد.

etwork Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.255.1, Interface address 192.168.1.2
Backup Designated Router (ID) 192.168.3.1, Interface address 192.168.1.3
From above, you can see that R3 has been elected as the new DR router.

R2#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
192.168.255.1 1 FULL/DR 00:00:38 192.168.1.2 GigabitEthernet0/0
192.168.3.1 1 FULL/BDR 00:00:39 192.168.1.3 GigabitEthernet0/0
192.168.12.1 0 FULL/ – 00:00:38 192.168.12.1 Serial0/0/0

اکنون با نگاهی به روتر R2 در بالا، می‌توانید ببینید که روتر DR جدید دارای شناسه همسایه 192.168.255.1 است که روی روتر R3 پیکربندی شده است.

DR Election را با استفاده از اولویت OSPF تغییر دهید

اکنون بیایید ببینیم چگونه با افزایش اولویت OSPF در رابط R3 بر انتخابات DR تاثیر بگذاریم. ما اولویت OSPF را در رابط GigEthernet0/0 که به شبکه چند دسترسی متصل است تغییر می‌دهیم.

ابتدا بیایید Router-ID را از R3 حذف کنیم:

R3#conf t
R3(config)#router ospf 1
R3(config-router)#no router-id 192.168.255.1
R3(config-router)#end
R3#wr
R3#reload

توجه: بهتر است همه روترهای دیگر را نیز بارگذاری مجدد کنید.

اگر “show ip ospf near” را روی R3 اجرا کنید، خواهید دید که DR اکنون دوباره مانند قبل روتر R2 است.

اکنون، بیایید یک اولویت OSPF را در R3 پیکربندی کنیم که باید بالاتر از 1 (پیش‌فرض) باشد:

R3#conf t
R3(config)#interface GigabitEthernet0/0
R3(config-if)#ip ospf priority 10
R3(config-if)#end

R3#clear ip ospf process

Let’s verify again which is the new DR router:

R2#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface

192.168.3.1 1 FULL/BDR 00:00:39 192.168.1.3 GigabitEthernet0/0
192.168.2.1 10 FULL/DR 00:00:33 192.168.1.2 GigabitEthernet0/0
192.168.12.1 0 FULL/ – 00:00:30 192.168.12.1 Serial0/0/0

From Router R2, you can see that the DR is now R3 (192.168.2.1) with a Priority (Pri) of 10.

نتیجه

در این مطلب به آموزش پیکربندی DR/BDR در پروتکل OSPF برای روتر سیسکو پرداختیم. امیدواریم این آموزش برای شما عزیزان مفید بوده باشد برای خواندن مطالب بیشتر در زمینه کانفیگ تجهیزات سیسکو شبکه دیده بان را دنیبال کنید.

جهت اطلاع از قیمت انواع تجهیزات شبکه سیسکو با شبکه دیده‌بان تماس بگیرید : 20 21 9100 – 021

مراحل ثبت سفارش تعمیر تجهیزات شبکه :
  • تماس با دفتر و ارسال تجهیزات به دفتر شبکه دیده بان
  • بررسی مشکلات تجهیزات شبکه و اعلام هزینه به شما
  • در صورت تایید شما ، تعمیر انجام می شود.
  • ارسال تجهیزات در اسرع وقت
نکات مهم پروسه تعمیرات تجهیزات شبکه :
  1. مشکل و ایرادات احتمالی دستگاه را در برگه‌ای نوشته و همراه دستگاه به دفتر شبکه دیده‌بان ارسال فرمایید.
  2. نام و شماره تلفن مسئول پیگیری تجهیزات را حتما درج بفرمایید.
  3. به دلیل زیاد بودن تعداد کالاهای تعمیری ، حتما پیگیر کالای خود باشید.

شبکه دیده بان وارد کننده و ارائه کننده انواع تجهیزات شبکه برند های معروف است. از جمله خدمات مجموعه حرفه ای شبکه دیده بان :

  • 48 ساعت مهلت تست
  • یک سال گارانتی
  • ارسال در اسرع وقت به تمام نقاط ایران
  • مشاوره رایگان قبل از خرید محصول
  • امکان کانفیگ و راه اندازی بعد از خرید محصول
  • تعمیر تجهیزات شبکه

جهت سفارش یا مشاوره با کارشناسان فروش با شماره های زیر تماس بگیرید :

02191002120

09128005038

سایت های شبکه دیده بان :

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *